Recent Posts

Pages: [1] 2 3 ... 10
1
General Help & How-To / Saved Follow ups are missing
« Last post by ccroasmun on February 14, 2017, 01:35:39 am »
I've had an unfortunate series of events and I'm not sure where to start fixing my ListmailPro.

1.  One of my lists disappeared.  It was a test list that I used to send things to myself to preview emails.  I did not worry too much about it.

2.  We tried to make a new test list and it was immediately populated with strange email addresses that were not from our client list. 

3.  People started receiving blank emails -- even though the follow ups for each list were set properly and the follow emails were in there.

3.  We did a sweep of our server, it found malware, cleaned it and then put up a firewall.

4.  We went back into ListmailPro.  Each list has its followups, but when I go to "Saved Followups", the names of the follow up lists are there, but none of them emails come up.

5.  I am unable to add people to lists.  It says it adds them and then when I click away and come back, the email address is not there.

--------------

Should I try to install Listmail Pro again? 

Does anyone know where the follow ups are stored in the databases?   I want to make sure I did not loose them.   There is over 10 years of work in there  :-[

I'm open to any suggestions.

Thanks!
2
General Help & How-To / Custom HTML not saving
« Last post by ioanevans on January 05, 2017, 06:04:03 pm »
Hi

I go to Custom HTML, then change the message click Save HTML.

It takes me to a list, so i go back and the change has not been made.

The same is true if i try and rename a custom html name or add in a URL, nothing is saved. I can create a new custom html but i cannot amend any of the details. How can i fix this please?

Regards

Ioan
3
General Help & How-To / Re: Server Migration
« Last post by mike_mac on November 23, 2016, 04:58:28 pm »
isp support have now resolved the issue, this was their reply for reference:

This is an sql-mode issue, the mode defines what SQL syntax should be supported and what kind of data validation should be performed. In this situation, what is happening is that the script is attempting to insert or update a row with the integer entry taking on either the default value (e.g., of 0 or NULL) or the next AUTO_INCREMENT value.
But MySQL is not interpreting this action as valid due to its SQL_MODE being in STRICT mode, so we have disabled it and restarted the MySQL service.

they also rolled it back to MySQL 5.55 (from 5.6)
4
General Help & How-To / Re: Server Migration
« Last post by mike_mac on November 23, 2016, 12:40:15 pm »
everything seems to give the same error (this while trying to manually run dailymail:
Incorrect integer value: '' for column 'id' at row 1
5
General Help & How-To / Re: Server Migration
« Last post by mike_mac on November 23, 2016, 11:26:38 am »
Cannot send message either, "Incorrect integer value: '' for column 'id' at row 1"
6
General Help & How-To / Server Migration
« Last post by mike_mac on November 23, 2016, 11:17:18 am »
Hi

My server has recently migrated and this has thrown up several issues;

Message content not loading - to which i found the PHP htmlspecialchars function fix and it seems to have worked
New messages not saving
New links not saving
New follow ups not saved
New hits not registering

So it seems Listmail can not now add new records to the DB, although I can edit existing messages links etc.

thanks

Mike
7
General Help & How-To / Re: Cron Job
« Last post by jon2 on November 09, 2016, 11:46:11 am »
Thanks Dean, it is now working. Problem 2.

I only have 115 subscribers right now. When I send a mail it stops at 50 and says to check configuration. The settings are at the default 1000. I changed to 500 and it still pauses and I have to hit resume 2 times to send them all.  What do I look for to fix this? It was working OK until a couple weeks ago. Did they restrict something on the server at my Host?

Jon
8
General Help & How-To / Re: Cron Job
« Last post by DW on November 07, 2016, 12:16:17 pm »
Hi Jon,

It looks like you have entered the timing part (0 0 * * *, which means daily at midnight) in the area where just the command should go. You may have to separate the timing from the command (/usr/bin/wget ...) and enter the timing manually using other inputs depending on your web hosting control panel.

Regards
9
General Help & How-To / Re: Cron Job
« Last post by jon2 on November 07, 2016, 09:48:03 am »
Took off the end like you suggested Dean and it ran. Now I get a email with this -   /bin/sh: 0: command not found.

this is the code I have in there. 0 0 * * * /usr/bin/wget -O /dev/null -T 0 http://online-ministries.org/news-alerts/dailymail.php?pw=password

Jon
10
General Help & How-To / Re: Sending error. Check your mail settings.
« Last post by DW on November 06, 2016, 01:14:29 pm »
Hi Michael,

The screen being blank is likely because of PHP output buffering. LMP should be improved to use an AJAX background sending process and queue checking script instead of a "live" page that continually runs in the browser. You can try customizing your PHP configuration to get the live experience back. In the PHP.INI you would disable compression, e.g. zlib, and set output_buffering to Off. If your system uses a proxy like Nginx or other it becomes more difficult as buffering would likely need to be disabled there, too. If none of that works an option may be to modify domail.php to output a string of spaces along with the counter update javascript to defeat any remaining buffer, e.g. after this line at 1768 (v1.88):

Code: [Select]
echo "<script language=javascript>document.s.speed2.value='$hr'</script>\n";
You could additionally output 4096 bytes of space:

Code: [Select]
echo str_repeat(' ',4096);
As for the error, if you have AUTH enabled you may be caught by a reconnection bug where the AUTH LOGIN capability is not detected properly due to the server returning AUTH PLAIN LOGIN. In admin.php on line 1522 change this:

Code: [Select]
          if($mtauth && strpos($srvmsg,'AUTH LOGIN')>0){

to this:

Code: [Select]
          if($mtauth && strpos($srvmsg,'LOGIN')>0){

Regards
Pages: [1] 2 3 ... 10